Some Bitfocus Inc. Call Numbers Ringing Busy
Incident Report for Bitfocus
Resolved
This incident has been resolved.
Posted Oct 09, 2024 - 11:58 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 09, 2024 - 10:41 PDT
Investigating
Some of the 'Contact Support' phone numbers that are on our community landing pages are ringing busy. That condition is preventing some customers from connecting with our live agents for support needs. We are actively working with one of our phone vendors and expect the issue to be resolved soon.

In the interim, to get in touch with our live support agents, please call phone number 1 888 505 1832. Thank you.
Posted Oct 09, 2024 - 10:18 PDT
This incident affected: Bitfocus Call Center.