Bitfocus/Clarity Human Services Support Center Is Down
Incident Report for Bitfocus
Resolved
This incident has been resolved.
Posted Mar 12, 2024 - 10:11 PDT
Monitoring
A fix has been implemented and we are monitoring the current operational status.
Posted Mar 12, 2024 - 09:37 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 12, 2024 - 09:34 PDT
Investigating
Presently, there appears to be an error at our vendor level that is impacting our support team's access to our ticketing system. We are working with the vendor to identify the issue and get it resolved ASAP.

Please expect delays in our response times while we work diligently with out vendor to get this resolved. We will provide updates as they become available.
Posted Mar 12, 2024 - 08:48 PDT
This incident affected: Bitfocus Call Center.