Longer Than Normal Load Times in Clarity Human Services (HMIS)
Incident Report for Bitfocus
Resolved
This incident has been resolved.
Posted Oct 08, 2024 - 16:31 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 08, 2024 - 15:56 PDT
Identified
Some customers are experiencing longer than normal page load times within Clarity Human Services. We have identified the issue and are actively working to resolve it.

The system is operational with degraded performance.
Posted Oct 08, 2024 - 10:48 PDT
This incident affected: Clarity Human Services.