Slow Connection Issue
Incident Report for Bitfocus, Inc.
Resolved
This incident has been resolved.
Posted 15 days ago. Apr 03, 2019 - 13:29 PDT
Investigating
We are currently looking into reports that some users are experiencing slight delaying in connecting to Clarity.
Posted 15 days ago. Apr 03, 2019 - 13:27 PDT
This incident affected: Clarity Human Services.